Home :: Documentation :: Download :: Development :: Community :: Ports :: Packages :: Bugs :: Links :: About :: Donors
Attached to Project: CRUX-ARM
Opened by Victor Martinez - 2012-11-03
Last edited by Jose V Beneyto - 2013-11-02

FS#42 - initrd miss ext3 and ext4 support.

Busybox lacks ext3 and ext4 support. Do we need to build util-linux and e2fsprogs statically and add them to initrd?
Another options?

Closed by  Jose V Beneyto
Saturday, 02 November 2013, 00:39 GMT
Reason for closing:  Fixed
Project Manager
Jose V Beneyto commented on Thursday, 17 October 2013, 14:20 GMT

well, it is a bit more complex but now it is possible to have ext3, ext4, and other filesystem format support

I tried that and worked just fine:

- put uImage, uInitrd, boot.scr, rootfs.tar.xz, modules.tar.xz and in a first partition of an SD card

- boot the efikamx (ramdisk option)

- after shell appeared and CRUX media is properly mounted:

# mount -o remount,rw /media
# mkdir /media/rootfs
# tar -C /media/rootfs -xpvf /media/crux-arm-rootfs-3.0-RC3-efikamx.tar.xz
# rmdir /mnt
# ln -s /media/rootfs /mnt
# setup-chroot

- once you're inside the new root you can use fdisk, cfdisk, mkfs* (ext2,ext3,ext4,reiserfs,xfs,jfs,etc. if you've the enough support in booted kernel)


Available keyboard shortcuts


Task Details

Task Editing